docker-compose


docker-compose the latest stable version on ubuntu


When I update docker-engine to the latest version on Ubuntu 16.04.1 LTS, I can see docker-engine is at the latest stable version based on https://github.com/docker/docker/blob/master/CHANGELOG.md
How come I don't see the latest stable version of docker-compose?
It is supposed to be 1.8.1 based on https://github.com/docker/compose/tags,
but it is 1.6.2 as you can see below
I couldn't find the information about apt-get install on official doc page: https://docs.docker.com/compose/install/
> apt-cache policy docker-engine
docker-engine:
Installed: 1.12.3-0~xenial
Candidate: 1.12.3-0~xenial
> docker --version
Docker version 1.12.3, build 6b644ec
> docker-compose --version
docker-compose version 1.6.2, build 4d72027
>lsb_release -a
Distributor ID: Ubuntu
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial
You can install with
sudo curl -o /usr/local/bin/docker-compose -L "https://github.com/docker/compose/releases/download/1.8.1/docker-compose-$(uname -s)-$(uname -m)"
and set permissions
sudo chmod +x /usr/local/bin/docker-compose
Ideally, it would be updated along with docker engine, but I didn't find the solution

Related Links

Docker compose lables constraint:node not work
is it possible to generate a random mysql password with dockercompose
Networking Docker Compose
How to change the config file for Riak TS when using Docker
Django Docker-compose machine does not start web server
How should docker-compose jobs discover etcd?
docker compose adding nodes dynamically to nginx frontend
Docker Swarm - dependencies definition
docker-compose volume not mounted
Exposing sentry service in docker-compose file
Yesod and docker-compose logs in development mode
Docker compose to always deploy using latest image
JHipster - Doubts in the development using Microservices Architecture
Gogs + Drone getsockopt: connection refused
Concourse result keeps loading
Docker-compose: AttributeError: 'module' object has no attribute 'ssl'

Categories

HOME
oop
ckan
grpc
android-ndk
arcgis
mifare
artifactory
glympse
richtextbox
opacity
markdown
cracking
http-status-codes
drush
derby
dat.gui
openscad
loader
ampscript
openoffice-basic
pushbullet
uipath
ppp
aws-certificate-manager
scalatest
continuous-fourier
smart-device
windows-10-mobile
custom-fields
azure-table-storage
restangular
sphinx4
federated
ipython-parallel
recreate
oracle-nosql
offset
pygraphviz
linkurious
definition
superclass
head
nshttpurlresponse
gradlew
nao-robot
history
extjs3
runtime-permissions
reloaddata
gevent
x12
disconnect
deck.js
normalisation
python-rq
stdlist
abstract
code-translation
skbio
markerspiderfier
encode
github-for-mac
updating
openhab
textblob
service-broker
method-overloading
uiblureffect
grunt-contrib-connect
powershell-v1.0
livescript
nsmutableurlrequest
msdropdown
behance-api
acrofields
mobile-robots
raddatepicker
zend-db-table
android-library
leap-year
qmainwindow
pageload
antixsslibrary
inflate
esi
github-archive
win-prolog
copyfile
visual-leak-detector
recess
symfony-1.2
netduino
s60
xcdatamodel
versions

Resources

Mobile Apps Dev
Database Users
javascript
java
csharp
php
android
MS Developer
developer works
python
ios
c
html
jquery
RDBMS discuss
Cloud Virtualization
Database Dev&Adm
javascript
java
csharp
php
python
android
jquery
ruby
ios
html
Mobile App
Mobile App
Mobile App