askbot


noob with askbot: questions don't get posted


I'm trying to set up an askbot project. I have followed the instructions mentioned here three times already (with git clone).
The problem is: I cannot post any question to the running site. I get no response when clicking on the ask question button.
Things I did differently from the tutorial were:
Set up the mysql user to be root instead of the one created in the tutorial because I got an inexistent user error.
Run a manage.py makemigrations and then manage.py migrate, as the prompt suggested them.
Set up my Base URL to be http://127.0.0.1:8000/.
Hope you guys can help out, I don't understand what's going on.
OK - found the issue. For some reason I wasn't able to catch, there was a log in the django console saying the following:
Exception happened during processing of request from ('127.0.0.1', 53242)
Traceback (most recent call last):
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 599, in process_request_thread
self.finish_request(request, client_address)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 334, in finish_request
self.RequestHandlerClass(request, client_address, self)
File "/Library/Python/2.7/site-packages/Django-1.8.13-py2.7.egg/django/core/servers/basehttp.py", line 102, in init
super(WSGIRequestHandler, self).init(*args, **kwargs)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 655, in init
self.handle()
File "/Library/Python/2.7/site-packages/Django-1.8.13-py2.7.egg/django/core/servers/basehttp.py", line 167, in handle
self.raw_requestline = self.rfile.readline(65537)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/socket.py", line 480, in readline
data = self._sock.recv(self._rbufsize)
timeout: timed out
Did a sudo pip install urllib3 (unaware why this solves the issue) and was able to post questions.

Related Links

noob with askbot: questions don't get posted
askbot-'askbot.deps.django_authopenid.forms.LoginForm object' has no attribute 'possword'
Askbot: Is posible to turn a whole askbot instance to “read only”?

Categories

HOME
spring-boot
drupal
repository
skype-for-business
url
locale
wifi
arcgis
terminal
yuv
revit-api
ios-universal-links
theory
distinct
chef-recipe
cakephp-2.0
exchange-transport-agents
ibatis
git-branch
dev-c++
wai-aria
aws-iot
windows-mobile
ballerinalang
libxml2
emr
intermec
exacttarget
directions
imageprocessor
bootcamp
matlab-compiler
respect-validation
lighting
rythm
instances
file-conversion
socketcluster
tapply
susy
delphi-xe
pyexcel
vpython
python-venv
nshttpurlresponse
google-chrome-storage
stanford-nlp-server
bioperl
senti-wordnet
trusted-computing
scanf
therubyracer
vertex-shader
stripes
joystick
networkstream
init
syslog4j
android-xmlpullparser
hotkeys
periodic-processing
videoview
google-app-engine-php
php-gd
waterline
genero
chunks
jsonschema2pojo
register-allocation
banana-pi
sendy
dayofweek
misfire-instruction
azure-pack
typography
azure-scheduler
invalidoperationexception
junit-rule
xcode4.6.3
waveout
optimistic-concurrency
pinchzoom
ruby-1.9
virtual-printer
symfony-1.2
jqtransform
virtual-destructor
nscharacterset
datadude
jgrowl
vista64

Resources

Encrypt Message